通达信macd连续20日翻红选股公式

macd在最近40天内有18天都是连续红柱的,天数最好能调节,要求是选股公式 通达信的

你还是专门找相关的程序员帮你编程吧

如何做“MACD连续N天红柱”的选股公式?

DIFF :=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD :=2*(DIFF-DEA);
COUNT(MACD>0,N)=N;

求一个通达信的选股公式 要求选出SAR为红色的股票,其中包括已经翻红好几天的和刚刚开始翻红的

别迷恋公式,如果公式能解决,股市早就崩盘了

强势整理+MACD二次翻红,改成通达信选股公式 谢谢!

DIF:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:2*(DIF-DEA),COLORSTICK;
股价上涨:HHV(C,4)/LLV(C,20)>1.15 AND HHV(MACD,3)/REF(HHV(MACD,1),20)>2;
红柱放大:COUNT(MACD>0,4)=4 AND COUNT(MACD<REF(MACD,1),4)>2 AND MACD>REF(MACD,1)AND MA(C,5)>REF(MA(C,5),1);
XG:股价上涨 AND 红柱放大;

macd周线金叉选股公式

XG:CROSS(MACD.DIF,MACD.DEA) AND CROSS(MACD.DIF#WEEK,MACD.DEA#WEEK); (信号非常少)

求大智慧MACD金叉选股公式。谢谢。

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
选股:CROSS(DIFF,DEA);